Skip to main content
Knowledgebase
Home
Renesas Singapore - Knowledgebase

"Data access info is not displayed on Trace pane in debugging RX MCU. "

Latest Updated:08/23/2013

Question:

I am debugging an RX family MCU in the CubeSuite+ environment using the E1 or E20 emulator. Though [Data access] is set as the trace data type, data access information is not displayed on the Trace panel.

Answer:

The following reasons may be preventing data access information from being displayed on the Trace panel.

  • Is the display mode set to [Source display mode]?
    Data access information is not displayed when the display mode is [Source display mode]. To display data access information, set the display mode as [Disassemble display mode] or [Mixed display mode]. The display mode can be set from the toolbar of the Trace panel or the context menu.

  • Is an RX600 series MCU being debugged while a point trace event is set?
    When a point trace event is set in the RX600 series MCU, trace data is not acquired unless the condition is satisfied. Open the Event panel and delete unnecessary point trace events.

  • Is an RX200 or RX100 series MCU being debugged?
    When [Data access] is set as the trace data type for an RX200 or RX100 series MCU, an address whose data is to be traced must be set as the condition for the point trace event. If no point trace event is set, trace data cannot be acquired.

    For details on the setting method, refer to CubeSuite+ Integrated Development Environment User's Manual: RX Debug from here.
Suitable Products
RX Family
CS+ (formerly CubeSuite+)
E1 [R0E000010KCE00]
E20 [R0E000200KCT00]