Skip to main content
Knowledgebase
Home
Renesas Singapore - Knowledgebase

Error occurs in attempting to debug RL78 MCU using E1/E20 in CubeSuite+

Latest Updated:10/02/2012

Question:

Though attempting to debug the RL78 family MCU using E1 or E20 in the CubeSuite+ environment, the following message is displayed when the debug tool is connected and the debug tool cannot be started up.

Error (E0210002)
Lanching debugger failed

[Direct Error Cause]
The ID code is incorrect. (C0602202)

Answer:

This error message is displayed when the security ID written in the flash memory does not match the security ID specified by the debug tool.

Confirm whether the security ID setting is the same in the flash memory and debug tool with reference to the following.

  • Security ID written in flash memory

    (a) When set in the user program
    The security ID is the value specified in addresses 0xC4 to 0xCD.

    (b) When set by the build tool's common option
    The security ID is the value specified by [security ID] in the [Device] category within the [Common Options] tab in the build tool property.

    Note: When both (a) and (b) are set, the setting of (b) is given priority.

  • Security ID specified by the debug tool
    The security ID is the value specified by [Flash] -> [ID code] in the [Connect Settings] tab on the Property panel of the debug tool.

If the user has forgotten the security ID to enable debugging, erase the flash memory and set the security ID again. The security ID after the flash memory has been erased is all 0s (00000000000000000000).

For details on the security ID in the flash memory and debug tool, refer to the following:
"E1/E20 Emulator Additional Document for User's Manual (Notes on Connection for RL78)" -> "3.1 Setting of Security ID"

Suitable Products
CS+ (formerly CubeSuite+)
E1 [R0E000010KCE00]
E20 [R0E000200KCT00]